Plaid Bank Account Connection Not Loading for Some Customers on E-Billing Invoices and Profiles

Incident Report for Maxio

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 10:43 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 10:41 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 08, 2026 - 10:39 EST

Investigating

We are currently investigating an issue preventing some customers from adding ACH info via Plaid to pay e-Bills and update their e-Bill Billing Profile.
Posted Jan 08, 2026 - 10:32 EST
This incident affected: Maxio Platform (Maxio Payments, e-Invoicing).