Maxio Payments - Failed Transactions
Incident Report for Maxio
Resolved
The incident has been resolved.
Posted Nov 14, 2023 - 12:33 EST
Monitoring
Transactions are now processing as expected and we will update affected customers with remediation steps if needed.
Posted Nov 14, 2023 - 10:28 EST
Investigating
We are currently investigating reports of a potential service interruption with one of our Maxio Payments partners. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Nov 14, 2023 - 09:16 EST
This incident affected: Maxio Platform (Maxio Payments).