Maxio Mandrill (Mailchimp) Issue
Incident Report for Maxio
Resolved
The Incident has been resolved and all emails sent will be delivered as Maxio works through the e-invoice email queue
Posted Aug 14, 2023 - 11:58 EDT
Identified
We are currently experiencing degraded performance issues with E-invoicing and have identified the issue. Our team is currently working to restore normal performance levels.
Posted Aug 14, 2023 - 11:53 EDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2023 - 11:47 EDT
Investigating
We are currently investigating reports of a potential service interruption with E-invoicing. Email delivery may be affected at this time. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Aug 14, 2023 - 11:47 EDT
This incident affected: Maxio Platform (Email Sending).