Maxio UI is currently experiencing issues
Incident Report for Maxio
Resolved
This incident has been resolved.
Posted May 19, 2024 - 11:38 EDT
Update
We are continuing to monitor for any further issues.
Posted May 19, 2024 - 11:11 EDT
Monitoring
We have implemented a solution and are currently monitoring the results.
Posted May 19, 2024 - 11:11 EDT
Investigating
We are currently investigating the issue.
Posted May 19, 2024 - 10:55 EDT
This incident affected: Maxio Platform (Main Application).