Billing Portal Temporarily Unreachable

Incident Report for Maxio

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 15:30 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 16, 2025 - 13:25 EDT

Monitoring

Between 11:24 to 11:40 Eastern (specific times dependent on DNS caching and propagation delays) billingportal.com was not reachable. This was due to an unexpected side-effect of planned DNS maintenance. Our team is currently monitoring as DNS caching and propagation delays may cause the portal to be temporarily unreachable for some customers.
Posted Jul 16, 2025 - 12:22 EDT
This incident affected: Maxio Advanced Billing (Billing Portal).