Email Sending Delays in Advanced Billing
Incident Report for Maxio
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 17:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2024 - 15:16 EDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2024 - 13:00 EDT
Investigating
Some Advanced Billing emails are experiencing delays in sending. While emails are sending correctly, there may be delays in sending and delivery. Our engineers are currently investigating.
Posted Apr 19, 2024 - 12:16 EDT
This incident affected: Maxio Advanced Billing (Email Sending).