Advanced Billing System Outage

Incident Report for Maxio

Resolved

This incident has been resolved. API calls, and signups/subscription creation attempts for sites during the full outage period time frame (13:12 UTC - 13:31 UTC) may have failed, and will need to be retried. Thank you for your patience as we worked to resolve this matter, and our sincere apologies for the disruption.
Posted Oct 27, 2025 - 10:52 EDT

Update

We are continuing to monitor as there are still some intermittent errors occurring. Exports have been paused for the time being while we work to fully recover.
Posted Oct 27, 2025 - 10:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 09:35 EDT

Investigating

We are currently investigating a system outage with Advanced Billing. Thank you for your patience as we work to resolve this as quickly as possible, and our apologies for the disruption.
Posted Oct 27, 2025 - 09:21 EDT
This incident affected: Maxio Advanced Billing (Main Application, Billing Portal, API, Chargify.js (Maxio.js), Scheduled Payment Processing, Email Sending, Webhooks, Maxio Hosted Pages, Data Exports).