Maxio Platform 503 Error Access Issues

Incident Report for Maxio

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 16:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 15:54 EDT

Investigating

During a scheduled release that was not expected to cause downtime, an issue occurred that is currently causing certain Maxio platform accounts to be temporarily unavailable. Impacted users are receiving a 503 error when attempting to access their accounts.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Posted Apr 24, 2025 - 15:50 EDT
This incident affected: Maxio Platform (Main Application) and Intuit Developer Group QuickBooks Online API.